Speedometer failed but ODO and day-counters still work

My trusty old Mitsubitsu Space Star from 2000 or abouts recently ran out of juice because I left the lights on, and after jump-starting it this cold dark morning and driving it a bit to let the computer get re-acquainted with the engine, I noticed my speed indicator stuck at 0.

The car was itself running fine and the day-counter and ODO meter added up the kilometers, which was puzzling. Are they not running off the same sensor?

A quick round of Google showed me what must have happened; [1] , [2]  when jump-starting a car, or re-connecting it’s battery, voltage mulst have spiked which sometimes causes the Speedometer needle to go full 360..

Sample speedometer with needle in normal resting position

And indeed, on closer inspection I could see it was stuck on the other side of the little pin, unable to move any further.

Sample speedometer with needle on the wrong side of the ‘pin’.

Ready for an afternoon of taking things apart, I was pleasantly surprised at how simple the solution to this issue can be:

  1. For some cars, probably a bit more advanced than my humble Space Start, one can push down the reset button of the day-counter whilst, after or before inserting and turning the key for up to a full minute. I tried it all, to no avail.
  2. Mention was made of the display needing to be in ODO-mode for this to work but this does not apply to my car; switching between the A and B counters and repeating the above did not help either.
  3. In the end, what did reset the Space Star Speedometer was the simplest option on offer; disconnecting the battery (the “-” terminal) for a full five minutes, and then simply re-connecting the system.

After disconnecting the battery I could see the needle had moved back somewhat already and reconnecting it five minutes later, the needle jumped back to 0 and, on a test-drive, indicated as before.

That’s it. No disassembly, no visit to the garage, done in 5 minutes.

Setting up your iOS phone or tablet to sync with NextCloud

 

 

 

Any apps needing WebDav, for instance a Password Database wanting to put its database on a cloud, use:

  1. Protocol: HTTPS (preferred obviously, if you have a valid SSL certificate for your nextcloud install) or HTTP
  2. Host: nextcloud.yourdomain.com (replace with your NextCloud URL)
  3. Port: can be left blank in most instances
  4. Local Path: /remote.php/webdav/[your directory for the sync]
  5. Username: [your username]
  6. Password: [your password]

 

Activate Windows 10 on OEM pc’s after a fresh install

New PC’s are now delivered with a simple Windows sticker on the case, as opposed to the Windows Product Key that could be found on earlier hard-ware. So what to do after a fresh install of Windows 10?

  1. Find the Windows 10 Product Key in the PC’s Bios with OEMKEY. This handy utility can be downloaded from NeoSmart Technologies here.
  2. Note down the key, press start and type: SLMGR.VBS /IPK [windows key] to register the key in your Windows installation
  3. Now, activate Windows with SLMGR.VBS /ATO

This only works with machines for machines with an OEM licence and a ‘MSDM’ table in their Bios. If the OEMKEY tool fails to locate this, you will have to either find a sticker on the machine with the key or find out if this machine is using a Volume Licence, and download another W10 image applicable to that.

Style ContactForm7 entry fields like in the Divi Theme contact form

Divi builder, by Elegant Themes, is surely one of the most powerful and robust drag-and-drop site builders for WordPress. Trouble is, the built in contact form module is not very powerful or flexible.

Thus, I like to fall back on the proven (and extensible) ContactForm7 plugin for contact/inquiry forms, which offers everything I need and more. If only it would look the same as the rest of the Divi theme.

I’ve found this article on AgentWP: How To Make Contact Form 7 To Look Like Divi Contact Form Module, which I used as a base, and added some more fields for checkboxes, date-pickers etc..

.wpcf7-text, .wpcf7-textarea, .wpcf7-captchar, .wpcf7-date {
background-color: #eee !important;
border: none !important;
width: 100% !important;
-moz-border-radius: 0 !important;
-webkit-border-radius: 0 !important;
border-radius: 3px !important;
font-size: 20px;
color: #333 !important;
padding: 16px !important;
-moz-box-sizing: border-box;
-webkit-box-sizing: border-box;
box-sizing: border-box;
}
.wpcf7-submit {
color: #fff !important;
margin: 8px auto 0;
cursor: pointer;
font-size: 20px;
font-weight: 500;
-moz-border-radius: 3px;
-webkit-border-radius: 3px;
border-radius: 3px;
padding: 6px 20px;
line-height: 1.7em;
background: transparent;
border: 2px solid;
-webkit-font-smoothing: antialiased;
-moz-osx-font-smoothing: grayscale;
-moz-transition: all 0.2s;
-webkit-transition: all 0.2s;
transition: all 0.2s;
}
.wpcf7-submit:hover {
background-color: rgba(255,255,255,0.5);
border-color:rgba(255,255,255,0.3);
padding: 6px 20px !important;
}

This just leaves the issue of things not lining out properly, which I solved (ouch) with a table in the form, which I give the

nofancy

class, and after adding the below CSS this blends in nicely as well.


table.nofancy {
border: none;
}

table.nofancy td {
border: none;
padding: 10px 0px;
}

 

Hello world!

Welcome to WordPress. This is your first post. Edit or delete it, then start writing!